depot_tools fetch error

Trying to run the depot_tools command:

fetch chromium

threw error:

[E2020-03-22T18:26:51.022193-05:00 14184 0 venv.go:969] Command (cwd=C:\Users\username\AppData\Local\Temp\vpython_bootstrap189391042\packages\virtualenv-15.1.0): [C:\src\depot_tools\python.bat -B -E -s virtualenv.py –no-download C:\Users\username\.vpython-root\6d5f35]

Process output:

C:\src\depot_tools\bootstrap-3_8_0_chromium_8_bin\python\bin\python.exe: can’t open file ‘virtualenv.py’: [Errno 2] No such file or directory

It worked on a new local user. So I dug into the user profile where the problem occurred and found the root cause.

The culprit was an Autorun entry in the registry under this key:

HKEY_CURRENT_USER\Software\Microsoft\Command Processor

Name: Autorun
Type: REG_SZ
Data: cd /d D:\Documents

Deleted the Autorun entry from the registry and now fetch works.

reg delete "HKCU\Software\Microsoft\Command Processor" /v AutoRun

You can also launch cmd.exe with the /D option to disable execution of AutoRun commands from the registry and run fetch from that command prompt session. See cmd /? for more info.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s